easy_install Twisted: unable to find vcvarsall.bat

Error “unable to find vcvarsall.bat” generally means that Visual C++ need be installed.

But for installing Twisted we get another option: Twisted windows installer, please check here http://twistedmatrix.com/trac/wiki/Downloads

 

After installing it, if you try to “import twisted”, you will get ImportError: Twisted requires zope.interfaces: no module named zope.interface.

We can install this missed module by using easy_install:

easy_install zope.interface